System Requirements for using TreverityEDGE